All Questions



Light issue

Hi, I have an issue with lights. The coins are lit up brightly when they shouldn't (in the editor it shows them as not lit up, but when I play the game they do). See screenshot here:

I tried turning "Show behind parent" on/off, and it does change the effect in the editor, but makes no difference to the game? 

  • Nathan Lovato replied

    From the screenshot, it looks like the lighting is the same in the editor and game, but you have the light occluder shape preview darkening the coin in the editor.

    You can see the light leaks a lot into the floor and somewhat into the player. It does the same with the coins, but as they're smaller and bright in the first place, they look brightly lit.

    This has to do with our lighting settings. I set it to leak a lot in the video to give objects some kind of bump or volume.

    So I think what you get is normal. If you still have trouble and want me to look into it, could you upload your Godot project as a zip archive? So I can open it in Godot and troubleshoot there.