All Questions

Community

R
Brian Rogers

How to get auto-completion for static type hints?

Greetings, I'm enjoying the class very much. Congrats on a such well produced and informative class. My current question is about Auto-Completion. At the 3:00 mark on the Coding the State (1) video, the auto-complete options are different than mine. My version: _unhandled_input(event): The "Coding the State (1) " video @ 3 sec mark: _unhandled_input(event: InputEvent) -> void: is that a problem? or , do I need to enable something in preferences or Project settings? Thanks for your time, Brian
  • R
    Brian Rogers replied

    Hey anyone!

    Here's the answer to my own question!

    Go to the Editor menu on top bar. Select Editor Settings. On the General tab, go to Text Editor -->Completion. Enable "Add Type Hints" checkbox. Mine (Godot v3.2, beta4) was off by default.


    all better

  • Nathan Lovato replied

    Glad you could find it! I've updated the title of your post so people who have the same question can find the answer more easily.

  • G
    Greaby replied

    I've been wondering the same thing. Thanks for the answer!